Docker container running AirNav RadarBox's rbfeeder. Designed to work in tandem with sdr-enthusiasts/readsb-protobuf. Builds and runs on x86_64, arm64 and arm32v7.
rbfeeder pulls ModeS/BEAST information from a host or container providing ModeS/BEAST data, and sends data to RadarBox.
For more information on what rbfeeder is, see here: sharing-data.
latest(mainbranch,Dockerfile)latest_nohealthcheckis the same as thelatestversion above. However, this version has the docker healthcheck removed. This is done for people running platforms (such as Nomad) that don't support manually disabling healthchecks, where healthchecks are not wanted.- Version and architecture specific tags available
Currently, this image should pull and run on the following architectures:
amd64: Linux x86-64arm32v7,armv7l: ARMv7 32-bit (Odroid HC1/HC2/XU4, RPi 2/3)arm64,aarch64: ARMv8 64-bit (RPi 4 64-bit OSes)
First-time users should obtain a RadarBox sharing key.
In order to obtain a RadarBox sharing key, on the first run of the container, rbfeeder will generate a sharing key and print this to the container log.
timeout 300s docker run \
--rm \
-it \
-e BEASTHOST=YOURBEASTHOST \
-e LAT=YOURLATITUDE \
-e LONG=YOURLONGITUDE \
-e ALT=YOURALTITUDE \
ghcr.io/sdr-enthusiasts/docker-radarbox:latestThis will run the container for five minutes, allowing a sharing key to be generated.
You should obviously replace YOURBEASTHOST, YOURLATITUDE, YOURLONGITUDE and YOURALTITUDE with appropriate values.
Shortly after the container launches, you should be presented with:
[2020-04-02 11:36:31] Empty sharing key. We will try to create a new one for you!
[2020-04-02 11:36:32] Your new key is g45643ab345af3c5d5g923a99ffc0de9. Please save this key for future use. You will have to know this key to link this receiver to your account in RadarBox24.com. This key is also saved in configuration file (/etc/rbfeeder.ini)
Take a note of the sharing key, as you'll need it when launching the container.
If you're not a first time user and are migrating from another installation, you can retrieve your sharing key using either of the following methods:
- SSH onto your existing receiver and run the command
rbfeeder --showkey --no-start - SSH onto your existing receiver and run the command
grep key= /etc/rbfeeder.ini
docker run \
-d \
--rm \
--name rbfeeder \
-e TZ="YOURTIMEZONE" \
-e BEASTHOST=YOURBEASTHOST \
-e LAT=YOURLATITUDE \
-e LONG=YOURLONGITUDE \
-e ALT=YOURALTITUDE \
-e SHARING_KEY=YOURSHARINGKEY \
ghcr.io/sdr-enthusiasts/docker-radarbox:latestYou should obviously replace YOURBEASTHOST, YOURLATITUDE, YOURLONGITUDE, YOURALTITUDE and YOURSHARINGKEY with appropriate values.
For example:
docker run \
-d \
--rm \
--name rbfeeder \
-e TZ="Australia/Perth" \
-e BEASTHOST=readsb \
-e LAT=-33.33333 \
-e LONG=111.11111 \
-e ALT=90 \
-e SHARING_KEY=g45643ab345af3c5d5g923a99ffc0de9 \
ghcr.io/sdr-enthusiasts/docker-radarbox:latestPlease note, the altitude figure is given in metres and no units should be specified.
version: '2.0'
services:
rbfeeder:
image: ghcr.io/sdr-enthusiasts/docker-radarbox:latest
tty: true
container_name: rbfeeder
restart: always
environment:
- TZ=Australia/Perth
- BEASTHOST=readsb
- LAT=-33.33333
- LONG=111.11111
- ALT=90
- SHARING_KEY=g45643ab345af3c5d5g923a99ffc0de9version: '2.0'
services:
readsb:
image: ghcr.io/sdr-enthusiasts/docker-readsb-protobuf:latest
tty: true
container_name: readsb
restart: always
devices:
- /dev/bus/usb/001/007:/dev/bus/usb/001/007
command:
- --dcfilter
- --device-type=rtlsdr
- --fix
- --forward-mlat
- --json-location-accuracy=2
- --lat=-33.33333
- --lon=111.11111
- --metric
- --mlat
- --modeac
- --ppm=0
- --net
- --stats-every=3600
- --quiet
- --write-json=/var/run/readsb
rbfeeder:
image: ghcr.io/sdr-enthusiasts/docker-radarbox:latest
tty: true
container_name: rbfeeder
restart: always
environment:
- TZ=Australia/Perth
- BEASTHOST=readsb
- LAT=-33.33333
- LONG=111.11111
- ALT=90
- SHARING_KEY=g45643ab345af3c5d5g923a99ffc0de9Once your container is up and running, you should claim your receiver.
- Go to https://www.radarbox.com/
- Create an account or sign in
- Claim your receiver by visiting https://www.radarbox.com/raspberry-pi/claim and following the instructions
Before raising an issue regarding connection errors, please wait at least 10 minutes. The rbfeeder binary is configured to attempt to connect to a collection of servers in a round-robin method. It appears normal for some servers to reject the connection, so it may take several minutes to find an available server and connect.
You may also receive a spurious error Error authenticating Sharing-Key: Invalid sharing-key. Provided you have entered your sharing key correctly, just ignore this for several minutes.
Here is some example output with RBFeeder Version 1.0.8 (build 20220708190411) showing the aformentioned behaviour:
[rbfeeder] [2022-12-15 11:29:22] Starting RBFeeder Version 1.0.8 (build 20220708190411)
[rbfeeder] [2022-12-15 11:29:22] Using configuration file: /etc/rbfeeder.ini
[rbfeeder] [2022-12-15 11:29:22] Network-mode enabled.
[rbfeeder] [2022-12-15 11:29:22] Remote host to fetch data: readsb
[rbfeeder] [2022-12-15 11:29:22] Remote port: 30005
[rbfeeder] [2022-12-15 11:29:22] Remote protocol: BEAST
[rbfeeder] [2022-12-15 11:29:22] Using GNSS (when available)
[rbfeeder] [2022-12-15 11:29:22] Start date/time: 2022-12-15 11:29:22
[rbfeeder] [2022-12-15 11:29:22] Socket for ANRB created. Waiting for connections on port 32088
[rbfeeder] [2022-12-15 11:29:28] Can't connect to AirNav Server. Retry in 60 seconds.
[rbfeeder] [2022-12-15 11:30:33] Can't connect to AirNav Server. Retry in 60 seconds.
[rbfeeder] [2022-12-15 11:31:34] Connection established.
[rbfeeder] [2022-12-15 11:31:34] CPU Serial empty. Use MAC address instead.
[rbfeeder] [2022-12-15 11:31:35] Error authenticating Sharing-Key: Invalid sharing-key
[rbfeeder] [2022-12-15 11:31:45] Could not start connection. Timeout.
[rbfeeder] [2022-12-15 11:32:46] Connection established.
[rbfeeder] [2022-12-15 11:32:46] CPU Serial empty. Use MAC address instead.
[rbfeeder] [2022-12-15 11:32:47] Error authenticating Sharing-Key: Invalid sharing-key
[rbfeeder] [2022-12-15 11:32:56] Could not start connection. Timeout.
[rbfeeder] [2022-12-15 11:33:57] Connection established.
[rbfeeder] [2022-12-15 11:33:57] CPU Serial empty. Use MAC address instead.
[rbfeeder] [2022-12-15 11:33:58] Error authenticating Sharing-Key: Invalid sharing-key
[rbfeeder] [2022-12-15 11:34:08] Could not start connection. Timeout.
[rbfeeder] [2022-12-15 11:35:09] Connection established.
[rbfeeder] [2022-12-15 11:35:09] CPU Serial empty. Use MAC address instead.
[rbfeeder] [2022-12-15 11:35:10] Client type: Raspberry Pi
[rbfeeder] [2022-12-15 11:35:10] Connection with RadarBox24 server OK! Key accepted by server.
[rbfeeder] [2022-12-15 11:35:10] This is your station serial number: <REDACTED>
In the above instance, it took approximately 6 minutes from container start to connection established.
There are a series of available environment variables:
| Environment Variable | Purpose | Default |
|---|---|---|
BEASTHOST |
Required. IP/Hostname of a Mode-S/BEAST provider (dump1090/readsb) | readsb |
BEASTPORT |
Optional. TCP port number of Mode-S/BEAST provider (dump1090/readsb) | 30005 |
UAT_RECEIVER_HOST |
Optional. IP/Hostname of an external UAT decoded JSON provider (eg: dump978-fa). | |
UAT_RECEIVER_PORT |
Optional. TCP port number of the external UAT decoded JSON provider. | 30979 |
SHARING_KEY |
Required. Radarbox Sharing Key | |
LAT |
Required. Latitude of the antenna | |
LONG |
Required. Longitude of the antenna | |
ALT |
Required. Altitude in metres | |
TZ |
Optional. Your local timezone | GMT |
STATS_INTERVAL_MINUTES |
Optional. How often to print statistics, in minutes. | 5 |
VERBOSE_LOGGING |
Optional. Set to true for no filtering of rbfeeder logs. |
false |
DEBUG_LEVEL |
Optional. Set to any number between 0 and 8 to increase verbosity of rbfeeder logs. |
0 |
ENABLE_MLAT |
Option. Set to true to enable MLAT inside of the container. See MLAT note below |
true |
The following TCP ports are used by this container:
32088-rbfeederlistens on this port, however I can't find the use for this port...30105-mlat-clientlistens on this port to provide MLAT results.
You may find that MLAT in your container will often times spit out errors in your logs, such as
[rbfeeder] Disconnecting from mlat1.rb24.com:40900: No data (not even keepalives) received for 60 seconds
[rbfeeder] Connected to multilateration server at mlat1.rb24.com:40900, handshakingThis is likely, but not always, not caused by anything you are doing, but is instead caused by the Radarbox server itself and as such there isn't anything you can do to fix it. You will see in your Radarbox stats very little, if any, MLAT targets from your feeder while it is doing this.
To stop the feeder from spamming your logs you can set ENABLE_MLAT=false in your environment configuration for Radarbox and it will stop the MLAT service, and the log messages. Please note that if you do this, and you use MLAT Hub please remove Radarbox from your READSB_NET_CONNECTOR under MLAT Hub.
- All processes are logged to the container's stdout, and can be viewed with
docker logs [-f] container.
You can log an issue on the project's GitHub.
I also have a Discord channel, feel free to join and converse.
If you're getting continual segmentation faults inside this container, see: sdr-enthusiasts#16 (comment)